target/xtensa: avoid IHI for writes to non-executable memory
[openocd.git] / src / server / Makefile.am
index 89b5e364236c90ee2dfaa4e9ee2c4e8cae265dfb..13a591409329e5958f778d63bc4019e89aa6b239 100644 (file)
@@ -1,21 +1,18 @@
-INCLUDES = -I$(top_srcdir)/src/helper -I$(top_srcdir)/src/target -I$(top_srcdir)/src/flash -I$(top_srcdir)/src/jtag $(all_includes)
-METASOURCES = AUTO
-noinst_LIBRARIES = libserver.a
-noinst_HEADERS = server.h telnet_server.h gdb_server.h
-libserver_a_SOURCES = server.c telnet_server.c gdb_server.c
+# SPDX-License-Identifier: GPL-2.0-or-later
 
-if HTTPD
-libserver_a_SOURCES += httpd.c
-endif
+noinst_LTLIBRARIES += %D%/libserver.la
+%C%_libserver_la_SOURCES = \
+       %D%/server.c \
+       %D%/telnet_server.c \
+       %D%/gdb_server.c \
+       %D%/server.h \
+       %D%/telnet_server.h \
+       %D%/gdb_server.h \
+       %D%/tcl_server.c \
+       %D%/tcl_server.h \
+       %D%/rtt_server.c \
+       %D%/rtt_server.h \
+       %D%/ipdbg.c \
+       %D%/ipdbg.h
 
-
-# tcl server addons
-noinst_HEADERS += tcl_server.h
-libserver_a_SOURCES += tcl_server.c
-
-if HTTPD
-nobase_dist_pkglib_DATA = $(wildcard $(srcdir)/httpd/*.tcl)
-nobase_dist_pkglib_DATA += $(wildcard $(srcdir)/httpd/*.css)
-nobase_dist_pkglib_DATA += $(wildcard $(srcdir)/httpd/menu_cuts/*.png)
-endif
-AM_CPPFLAGS = -DPKGLIBDIR=\"$(pkglibdir)\" @CPPFLAGS@
\ No newline at end of file
+STARTUP_TCL_SRCS += %D%/startup.tcl

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)