cortex_a: allow physical memory access through AHB-AP again
[openocd.git] / src / target / Makefile.am
index cd9035513324d44d5a5b5b34b26c39e93783c2fc..1f4cbba42388cf01c7a68e1aba665bb1ce2c0bee 100644 (file)
@@ -1,3 +1,4 @@
+include $(top_srcdir)/common.mk
 
 if OOCD_TRACE
 OOCD_TRACE_FILES = oocd_trace.c
@@ -5,25 +6,22 @@ else
 OOCD_TRACE_FILES =
 endif
 
-AM_CPPFLAGS = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/helper \
-       -I$(top_srcdir)/src/jtag \
-       -I$(top_srcdir)/src/xsvf
+SUBDIRS = openrisc
+libtarget_la_LIBADD = $(top_builddir)/src/target/openrisc/libopenrisc.la
 
-BIN2C          = $(top_builddir)/src/helper/bin2char$(EXEEXT_FOR_BUILD)
+BIN2C          = $(top_srcdir)/src/helper/bin2char.sh
 
 DEBUG_HANDLER  = $(srcdir)/xscale/debug_handler.bin
 EXTRA_DIST = \
        startup.tcl \
-       $(DEBUG_HANDLER)
+       $(wildcard $(srcdir)/xscale/*)
 
-DEBUG_HEADER   = xscale_debug.h
+DEBUG_HEADER   = xscale_debug.inc
 BUILT_SOURCES = $(DEBUG_HEADER)
 CLEANFILES = $(DEBUG_HEADER)
 
-$(DEBUG_HEADER): $(BIN2C) $(DEBUG_HANDLER)
-       $(BIN2C) < $(DEBUG_HANDLER) xscale_debug_handler > xscale_debug.h
+$(DEBUG_HEADER): $(DEBUG_HANDLER) $(BIN2C)
+       $(BIN2C) < $< > $@ || { rm -f $@; false; }
 
 METASOURCES = AUTO
 noinst_LTLIBRARIES = libtarget.la
@@ -34,8 +32,15 @@ libtarget_la_SOURCES = \
        $(ARMV6_SRC) \
        $(ARMV7_SRC) \
        $(ARM_MISC_SRC) \
+       $(AVR32_SRC) \
        $(MIPS32_SRC) \
-       avrt.c
+       $(NDS32_SRC) \
+       $(INTEL_IA32_SRC) \
+       avrt.c \
+       dsp563xx.c \
+       dsp563xx_once.c \
+       dsp5680xx.c \
+       hla_target.c
 
 TARGET_CORE_SRC = \
        algorithm.c \
@@ -44,7 +49,8 @@ TARGET_CORE_SRC = \
        breakpoints.c \
        target.c \
        target_request.c \
-       testee.c
+       testee.c \
+       smp.c
 
 ARMV4_5_SRC = \
        armv4_5.c \
@@ -59,6 +65,7 @@ ARM7_9_SRC = \
        arm9tdmi.c \
        arm920t.c \
        arm966e.c \
+       arm946e.c \
        arm926ejs.c \
        feroceon.c
 
@@ -72,16 +79,22 @@ ARMV6_SRC = \
 
 ARMV7_SRC = \
        armv7m.c \
-       cortex_m3.c \
+       armv7m_trace.c \
+       cortex_m.c \
        armv7a.c \
-       cortex_a8.c
+       cortex_a.c
 
 ARM_DEBUG_SRC = \
        arm_dpm.c \
        arm_jtag.c \
        arm_disassembler.c \
        arm_simulator.c \
+       arm_semihosting.c \
        arm_adi_v5.c \
+       armv7a_cache.c \
+       armv7a_cache_l2x.c \
+       adi_v5_jtag.c \
+       adi_v5_swd.c \
        embeddedice.c \
        trace.c \
        etb.c \
@@ -89,6 +102,12 @@ ARM_DEBUG_SRC = \
        $(OOCD_TRACE_FILES) \
        etm_dummy.c
 
+AVR32_SRC = \
+       avr32_ap7k.c \
+       avr32_jtag.c \
+       avr32_mem.c \
+       avr32_regs.c
+
 MIPS32_SRC = \
        mips32.c \
        mips_m4k.c \
@@ -96,14 +115,36 @@ MIPS32_SRC = \
        mips32_dmaacc.c \
        mips_ejtag.c
 
+NDS32_SRC = \
+       nds32.c \
+       nds32_reg.c \
+       nds32_cmd.c \
+       nds32_disassembler.c \
+       nds32_tlb.c \
+       nds32_v2.c \
+       nds32_v3_common.c \
+       nds32_v3.c \
+       nds32_v3m.c \
+       nds32_aice.c
+
+INTEL_IA32_SRC = \
+       quark_x10xx.c \
+       quark_d20xx.c \
+       lakemont.c \
+       x86_32_common.c
 
 noinst_HEADERS = \
        algorithm.h \
+       arm.h \
        arm_dpm.h \
        arm_jtag.h \
        arm_adi_v5.h \
+       armv7a_cache.h \
+       armv7a_cache_l2x.h \
        arm_disassembler.h \
+       arm_opcodes.h \
        arm_simulator.h \
+       arm_semihosting.h \
        arm7_9_common.h \
        arm7tdmi.h \
        arm720t.h \
@@ -111,6 +152,7 @@ noinst_HEADERS = \
        arm920t.h \
        arm926ejs.h \
        arm966e.h \
+       arm946e.h \
        arm11.h \
        arm11_dbgtap.h \
        armv4_5.h \
@@ -118,10 +160,14 @@ noinst_HEADERS = \
        armv4_5_cache.h \
        armv7a.h \
        armv7m.h \
+       armv7m_trace.h \
        avrt.h \
+       dsp563xx.h \
+       dsp563xx_once.h \
+       dsp5680xx.h \
        breakpoints.h \
-       cortex_m3.h \
-       cortex_a8.h \
+       cortex_m.h \
+       cortex_a.h \
        embeddedice.h \
        etb.h \
        etm.h \
@@ -140,9 +186,27 @@ noinst_HEADERS = \
        target_request.h \
        trace.h \
        xscale.h \
-       xscale_debug.h
-
-nobase_dist_pkglib_DATA =
-nobase_dist_pkglib_DATA += ecos/at91eb40a.elf
+       smp.h \
+       avr32_ap7k.h \
+       avr32_jtag.h \
+       avr32_mem.h \
+       avr32_regs.h \
+       nds32.h \
+       nds32_cmd.h \
+       nds32_disassembler.h \
+       nds32_edm.h \
+       nds32_insn.h \
+       nds32_reg.h \
+       nds32_tlb.h \
+       nds32_v2.h \
+       nds32_v3_common.h \
+       nds32_v3.h \
+       nds32_v3m.h \
+       nds32_aice.h \
+       lakemont.h \
+       x86_32_common.h
+
+ocddatadir = $(pkglibdir)
+nobase_dist_ocddata_DATA =
 
 MAINTAINERCLEANFILES = $(srcdir)/Makefile.in

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)