quark: add Intel Quark mcu D2000 support
[openocd.git] / src / target / Makefile.am
index 1a2fbd6c68b3223992a31ef8c3044337cd467447..1f4cbba42388cf01c7a68e1aba665bb1ce2c0bee 100644 (file)
@@ -6,19 +6,22 @@ else
 OOCD_TRACE_FILES =
 endif
 
-BIN2C          = $(top_builddir)/src/helper/bin2char$(EXEEXT_FOR_BUILD)
+SUBDIRS = openrisc
+libtarget_la_LIBADD = $(top_builddir)/src/target/openrisc/libopenrisc.la
+
+BIN2C          = $(top_srcdir)/src/helper/bin2char.sh
 
 DEBUG_HANDLER  = $(srcdir)/xscale/debug_handler.bin
 EXTRA_DIST = \
        startup.tcl \
-       $(DEBUG_HANDLER)
+       $(wildcard $(srcdir)/xscale/*)
 
-DEBUG_HEADER   = xscale_debug.h
+DEBUG_HEADER   = xscale_debug.inc
 BUILT_SOURCES = $(DEBUG_HEADER)
 CLEANFILES = $(DEBUG_HEADER)
 
-$(DEBUG_HEADER): $(BIN2C) $(DEBUG_HANDLER)
-       $(BIN2C) < $(DEBUG_HANDLER) xscale_debug_handler > xscale_debug.h
+$(DEBUG_HEADER): $(DEBUG_HANDLER) $(BIN2C)
+       $(BIN2C) < $< > $@ || { rm -f $@; false; }
 
 METASOURCES = AUTO
 noinst_LTLIBRARIES = libtarget.la
@@ -31,9 +34,13 @@ libtarget_la_SOURCES = \
        $(ARM_MISC_SRC) \
        $(AVR32_SRC) \
        $(MIPS32_SRC) \
+       $(NDS32_SRC) \
+       $(INTEL_IA32_SRC) \
        avrt.c \
        dsp563xx.c \
-       dsp563xx_once.c
+       dsp563xx_once.c \
+       dsp5680xx.c \
+       hla_target.c
 
 TARGET_CORE_SRC = \
        algorithm.c \
@@ -72,7 +79,8 @@ ARMV6_SRC = \
 
 ARMV7_SRC = \
        armv7m.c \
-       cortex_m3.c \
+       armv7m_trace.c \
+       cortex_m.c \
        armv7a.c \
        cortex_a.c
 
@@ -83,7 +91,9 @@ ARM_DEBUG_SRC = \
        arm_simulator.c \
        arm_semihosting.c \
        arm_adi_v5.c \
-       adi_v5_jtag.c \
+       armv7a_cache.c \
+       armv7a_cache_l2x.c \
+       adi_v5_jtag.c \
        adi_v5_swd.c \
        embeddedice.c \
        trace.c \
@@ -105,6 +115,23 @@ MIPS32_SRC = \
        mips32_dmaacc.c \
        mips_ejtag.c
 
+NDS32_SRC = \
+       nds32.c \
+       nds32_reg.c \
+       nds32_cmd.c \
+       nds32_disassembler.c \
+       nds32_tlb.c \
+       nds32_v2.c \
+       nds32_v3_common.c \
+       nds32_v3.c \
+       nds32_v3m.c \
+       nds32_aice.c
+
+INTEL_IA32_SRC = \
+       quark_x10xx.c \
+       quark_d20xx.c \
+       lakemont.c \
+       x86_32_common.c
 
 noinst_HEADERS = \
        algorithm.h \
@@ -112,6 +139,8 @@ noinst_HEADERS = \
        arm_dpm.h \
        arm_jtag.h \
        arm_adi_v5.h \
+       armv7a_cache.h \
+       armv7a_cache_l2x.h \
        arm_disassembler.h \
        arm_opcodes.h \
        arm_simulator.h \
@@ -131,11 +160,13 @@ noinst_HEADERS = \
        armv4_5_cache.h \
        armv7a.h \
        armv7m.h \
+       armv7m_trace.h \
        avrt.h \
        dsp563xx.h \
        dsp563xx_once.h \
+       dsp5680xx.h \
        breakpoints.h \
-       cortex_m3.h \
+       cortex_m.h \
        cortex_a.h \
        embeddedice.h \
        etb.h \
@@ -155,9 +186,27 @@ noinst_HEADERS = \
        target_request.h \
        trace.h \
        xscale.h \
-       xscale_debug.h
-
-nobase_dist_pkglib_DATA =
-nobase_dist_pkglib_DATA += ecos/at91eb40a.elf
+       smp.h \
+       avr32_ap7k.h \
+       avr32_jtag.h \
+       avr32_mem.h \
+       avr32_regs.h \
+       nds32.h \
+       nds32_cmd.h \
+       nds32_disassembler.h \
+       nds32_edm.h \
+       nds32_insn.h \
+       nds32_reg.h \
+       nds32_tlb.h \
+       nds32_v2.h \
+       nds32_v3_common.h \
+       nds32_v3.h \
+       nds32_v3m.h \
+       nds32_aice.h \
+       lakemont.h \
+       x86_32_common.h
+
+ocddatadir = $(pkglibdir)
+nobase_dist_ocddata_DATA =
 
 MAINTAINERCLEANFILES = $(srcdir)/Makefile.in

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)