helper,rtos,server: Restore missing warning flags
[openocd.git] / src / rtos / Makefile.am
index 58923b844e9e9afc099e8c4e7bacd56f7f742b53..c59ee3f8c7b430952202375a561abce0326c6516 100644 (file)
@@ -1,34 +1,32 @@
-# ***************************************************************************
-# *   Copyright (C) 2011 by Broadcom Corporation                            *
-# *   Evan Hunter - ehunter@broadcom.com                                    *
-# *                                                                         *
-# *   This program is free software; you can redistribute it and/or modify  *
-# *   it under the terms of the GNU General Public License as published by  *
-# *   the Free Software Foundation; either version 2 of the License, or     *
-# *   (at your option) any later version.                                   *
-# *                                                                         *
-# *   This program is distributed in the hope that it will be useful,       *
-# *   but WITHOUT ANY WARRANTY; without even the implied warranty of        *
-# *   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the         *
-# *   GNU General Public License for more details.                          *
-# *                                                                         *
-# *   You should have received a copy of the GNU General Public License     *
-# *   along with this program; if not, write to the                         *
-# *   Free Software Foundation, Inc.,                                       *
-# *   51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.           *
-# ***************************************************************************
+noinst_LTLIBRARIES += %D%/librtos.la
+%C%_librtos_la_SOURCES = \
+       %D%/rtos.c \
+       %D%/rtos_standard_stackings.c \
+       %D%/rtos_ecos_stackings.c  \
+       %D%/rtos_chibios_stackings.c \
+       %D%/rtos_embkernel_stackings.c \
+       %D%/rtos_mqx_stackings.c \
+       %D%/rtos_ucos_iii_stackings.c \
+       %D%/FreeRTOS.c \
+       %D%/ThreadX.c \
+       %D%/eCos.c \
+       %D%/linux.c \
+       %D%/ChibiOS.c \
+       %D%/embKernel.c \
+       %D%/mqx.c \
+       %D%/uCOS-III.c \
+       %D%/rtos.h \
+       %D%/rtos_standard_stackings.h \
+       %D%/rtos_ecos_stackings.h \
+       %D%/linux_header.h \
+       %D%/rtos_chibios_stackings.h \
+       %D%/rtos_embkernel_stackings.h \
+       %D%/rtos_mqx_stackings.h \
+       %D%/rtos_ucos_iii_stackings.h
 
-include $(top_srcdir)/common.mk
+%C%_librtos_la_CFLAGS = $(AM_CFLAGS)
 
-METASOURCES = AUTO
-noinst_LTLIBRARIES = librtos.la
-noinst_HEADERS = rtos.h rtos_standard_stackings.h rtos_ecos_stackings.h linux_header.h rtos_chibios_stackings.h rtos_embkernel_stackings.h
-librtos_la_SOURCES = rtos.c rtos_standard_stackings.c rtos_ecos_stackings.c  rtos_chibios_stackings.c rtos_embkernel_stackings.c FreeRTOS.c ThreadX.c eCos.c linux.c ChibiOS.c embKernel.c
-
-librtos_la_CFLAGS =
 if IS_MINGW
 # FD_* macros are sloppy with their signs on MinGW32 platform
-librtos_la_CFLAGS += -Wno-sign-compare
+%C%_librtos_la_CFLAGS += -Wno-sign-compare
 endif
-
-MAINTAINERCLEANFILES = $(srcdir)/Makefile.in

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)