Remove support for the GPL incompatible FTDI D2XX library
[openocd.git] / src / jtag / drivers / Makefile.am
index 2aaf8fd8420b604cf232e25f92ea0bf046060851..1322c0f10e8fb48decc88c97422c8dc036e66327 100644 (file)
@@ -33,6 +33,7 @@ noinst_LTLIBRARIES += libjaylink_internal.la
 libocdjtagdrivers_la_LIBADD += libjaylink_internal.la
 else
 DRIVERFILES += jlink.c
+libocdjtagdrivers_la_CPPFLAGS += $(libjaylink_CFLAGS)
 endif
 endif
 
@@ -59,9 +60,6 @@ endif
 if DUMMY
 DRIVERFILES += dummy.c
 endif
-if FT2232_DRIVER
-DRIVERFILES += ft2232.c
-endif
 if FTDI
 DRIVERFILES += ftdi.c mpsse.c
 endif
@@ -87,7 +85,7 @@ endif
 if BITQ
 DRIVERFILES += bitq.c
 endif
-if PRESTO_DRIVER
+if PRESTO
 DRIVERFILES += presto.c
 endif
 if USBPROG
@@ -147,7 +145,6 @@ endif
 noinst_HEADERS = \
        bitbang.h \
        bitq.h \
-       ftd2xx_common.h \
        libusb0_common.h \
        libusb1_common.h \
        libusb_common.h \
@@ -166,8 +163,10 @@ noinst_HEADERS = \
 
 DIST_SUBDIRS = usb_blaster
 
+if JLINK
 if INTERNAL_LIBJAYLINK
 DIST_SUBDIRS += libjaylink
 endif
+endif
 
 MAINTAINERCLEANFILES = $(srcdir)/Makefile.in

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)