jim-nvp is moving from jimtcl to openocd
[openocd.git] / src / helper / Makefile.am
index 27ae1e20b35a200d39152fe0834fbf630e9a0ffb..c9479b43edb18aba62a6f098f952e75d63059262 100644 (file)
@@ -1,7 +1,4 @@
-AM_CPPFLAGS = \
-       -I$(top_srcdir)/src \
-       -I$(top_builddir)/src \
-       -DPKGDATADIR=\"$(pkgdatadir)\"
+include $(top_srcdir)/common.mk
 
 METASOURCES = AUTO
 noinst_LTLIBRARIES = libhelper.la
@@ -9,7 +6,7 @@ noinst_LTLIBRARIES = libhelper.la
 if ECOSBOARD
 CONFIGFILES = time_support_ecos.c
 else
-CONFIGFILES = options.c jim.c jim-eventloop.c time_support_common.c
+CONFIGFILES = options.c time_support_common.c
 endif
 
 
@@ -22,7 +19,9 @@ libhelper_la_SOURCES = \
        command.c \
        time_support.c \
        replacements.c \
-       fileio.c
+       fileio.c \
+       util.c \
+       jim-nvp.c
 
 if IOUTIL
 libhelper_la_SOURCES += ioutil.c
@@ -40,16 +39,16 @@ noinst_HEADERS = \
        binarybuffer.h \
        configuration.h \
        ioutil.h \
+       util.h \
        types.h \
        log.h \
        command.h \
        time_support.h \
        replacements.h \
        fileio.h \
-       jim.h \
-       jim-eventloop.h \
        system.h \
-       bin2char.c
+       bin2char.c \
+       jim-nvp.h
 
 EXTRA_DIST = startup.tcl
 

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)