Add a bit-level transfer queue
[openocd.git] / src / helper / Makefile.am
index 244ada7cd80564500d46e7ed04712c1bb4ad4377..9e27d051ef7d38a861fcd021c1f966903ac07e2c 100644 (file)
@@ -1,18 +1,9 @@
-AM_CPPFLAGS = \
-       -I$(top_srcdir)/src \
-       -I$(top_builddir)/src \
-       -DPKGDATADIR=\"$(pkgdatadir)\"
+include $(top_srcdir)/common.mk
 
 METASOURCES = AUTO
 noinst_LTLIBRARIES = libhelper.la
 
-if ECOSBOARD
-CONFIGFILES =
-else
-CONFIGFILES = options.c jim.c jim-eventloop.c
-endif
-
-
+CONFIGFILES = options.c time_support_common.c
 
 libhelper_la_SOURCES = \
        binarybuffer.c \
@@ -23,7 +14,8 @@ libhelper_la_SOURCES = \
        time_support.c \
        replacements.c \
        fileio.c \
-       membuf.c
+       util.c \
+       jim-nvp.c
 
 if IOUTIL
 libhelper_la_SOURCES += ioutil.c
@@ -41,17 +33,17 @@ noinst_HEADERS = \
        binarybuffer.h \
        configuration.h \
        ioutil.h \
+       list.h \
+       util.h \
        types.h \
        log.h \
        command.h \
-       membuf.h \
        time_support.h \
        replacements.h \
        fileio.h \
-       jim.h \
-       jim-eventloop.h \
        system.h \
-       bin2char.c
+       bin2char.c \
+       jim-nvp.h
 
 EXTRA_DIST = startup.tcl
 

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)