jtag: drivers: usb_blaster: clarify lowlevel driver selection code 31/3931/2
authorPaul Fertser <fercerpav@gmail.com>
Fri, 30 Dec 2016 21:04:48 +0000 (00:04 +0300)
committerPaul Fertser <fercerpav@gmail.com>
Sat, 27 Jan 2018 17:16:02 +0000 (17:16 +0000)
commite60573c528081cbf10269ea447e8c3521fddeed0
tree05b189b0e6f58cbb204df783308844662f200cd6
parenta0c4c9e717d17b1c706f27ece5ce43b6acfa0ba7
jtag: drivers: usb_blaster: clarify lowlevel driver selection code

This patch should make the code logic more transparent and user
notifications more useful.

It also fixes a warning "array subscript is below array bounds" that
leads to FTBFS on Raspbian GNU/Linux 8 (jessie).

Change-Id: I626b6a5bc013dfee7d36cf196f0abab981d30675
Signed-off-by: Paul Fertser <fercerpav@gmail.com>
Reviewed-on: http://openocd.zylin.com/3931
Tested-by: jenkins
src/jtag/drivers/usb_blaster/usb_blaster.c