stlink: simplify api version handling 12/4712/2
authorAntonio Borneo <borneo.antonio@gmail.com>
Sun, 23 Sep 2018 15:05:05 +0000 (17:05 +0200)
committerSpencer Oliver <spen@spen-soft.co.uk>
Thu, 6 Dec 2018 13:05:38 +0000 (13:05 +0000)
commit80ce68b42cd1851f0c77a2e0fa88bb44ec15c0b7
tree1ae284af6f8063b1536419f95ec1e82b69e2a615
parent861730f73230d764e0309422556bc5f7ab33e94f
stlink: simplify api version handling

The API version is hardcoded in the STLINK device and depends on
the specific firmware version. There is no way to switch between
different API. Thus, it make no sense to keep in two separate
variables the current and the max API supported because they are
always equal to "the only" API supported by the specific STLINK.

Collapse h->version.jtag_api_max and h->jtag_api in a single
variable h->version.jtag_api
Remove an extra print of api version; this is already advertised
while printing the STLINK version.

Change-Id: I0519694a34748e5a0aa330932c1256080a6d5f20
Signed-off-by: Antonio Borneo <borneo.antonio@gmail.com>
Reviewed-on: http://openocd.zylin.com/4712
Tested-by: jenkins
Reviewed-by: Spencer Oliver <spen@spen-soft.co.uk>
src/jtag/drivers/stlink_usb.c