Fix make maintainer-clean for out-of-tree builds.
[openocd.git] / src / target / Makefile.am
index 832ff7390cc56d19cd46e73ecf6902d5d25e8051..70b4df783081d273b0888ef2d4ad8b70ff8c5626 100644 (file)
@@ -5,19 +5,97 @@ else
 OOCD_TRACE_FILES =
 endif
 
-INCLUDES = -I$(top_srcdir)/src/gdb -I$(top_srcdir)/src/helper  -I$(top_srcdir)/src/jtag -I$(top_srcdir)/src/xsvf $(all_includes)
+AM_CPPFLAGS = \
+       -I$(top_srcdir)/src/helper \
+       -I$(top_srcdir)/src/jtag \
+       -I$(top_srcdir)/src/xsvf
+
 METASOURCES = AUTO
-AM_CPPFLAGS = -DPKGLIBDIR=\"$(pkglibdir)\" @CPPFLAGS@
-noinst_LIBRARIES = libtarget.a
-libtarget_a_SOURCES = target.c register.c breakpoints.c armv4_5.c embeddedice.c etm.c arm7tdmi.c arm9tdmi.c \
-       arm_jtag.c arm7_9_common.c algorithm.c arm920t.c arm720t.c armv4_5_mmu.c armv4_5_cache.c arm_disassembler.c \
-       arm966e.c arm926ejs.c feroceon.c etb.c xscale.c arm_simulator.c image.c armv7m.c cortex_m3.c cortex_swjdp.c \
-       etm_dummy.c $(OOCD_TRACE_FILES) target_request.c trace.c
-noinst_HEADERS = target.h trace.h register.h armv4_5.h embeddedice.h etm.h arm7tdmi.h arm9tdmi.h \
-       arm_jtag.h arm7_9_common.h arm920t.h arm720t.h armv4_5_mmu.h armv4_5_cache.h breakpoints.h algorithm.h \
-       arm_disassembler.h arm966e.h arm926ejs.h etb.h xscale.h arm_simulator.h image.h armv7m.h cortex_m3.h cortex_swjdp.h \
-       etm_dummy.h oocd_trace.h target_request.h trace.h
+noinst_LTLIBRARIES = libtarget.la
+libtarget_la_SOURCES = \
+       target.c \
+       register.c \
+       breakpoints.c \
+       armv4_5.c \
+       embeddedice.c \
+       etm.c \
+       arm7tdmi.c \
+       arm9tdmi.c \
+       arm_jtag.c \
+       arm7_9_common.c \
+       algorithm.c \
+       arm920t.c \
+       arm720t.c \
+       armv4_5_mmu.c \
+       armv4_5_cache.c \
+       arm_disassembler.c \
+       arm966e.c \
+       arm926ejs.c \
+       feroceon.c \
+       etb.c \
+       xscale.c \
+       arm_simulator.c \
+       image.c \
+       armv7m.c \
+       cortex_m3.c \
+       cortex_a8.c \
+       arm_adi_v5.c \
+       etm_dummy.c \
+       $(OOCD_TRACE_FILES) \
+       target_request.c \
+       trace.c \
+       arm11.c \
+       arm11_dbgtap.c \
+       mips32.c \
+       mips_m4k.c \
+       mips32_pracc.c \
+       mips32_dmaacc.c \
+       mips_ejtag.c \
+       avrt.c
 
-nobase_dist_pkglib_DATA = xscale/debug_handler.bin event/at91eb40a_reset.cfg target/at91eb40a.cfg
+noinst_HEADERS = \
+       target.h \
+       target_type.h \
+       trace.h \
+       register.h \
+       armv4_5.h \
+       embeddedice.h \
+       etm.h \
+       arm7tdmi.h \
+       arm9tdmi.h \
+       arm_jtag.h \
+       arm7_9_common.h \
+       arm920t.h \
+       arm720t.h \
+       armv4_5_mmu.h \
+       armv4_5_cache.h \
+       breakpoints.h \
+       algorithm.h \
+       arm_disassembler.h \
+       arm966e.h \
+       arm926ejs.h \
+       etb.h \
+       xscale.h \
+       arm_simulator.h \
+       image.h \
+       armv7m.h \
+       cortex_m3.h \
+       cortex_a8.h \
+       arm_adi_v5.h \
+       etm_dummy.h \
+       oocd_trace.h \
+       target_request.h \
+       trace.h \
+       arm11.h \
+       mips32.h \
+       mips_m4k.h \
+       mips_ejtag.h \
+       mips32_pracc.h \
+       mips32_dmaacc.h \
+       avrt.h
 
+nobase_dist_pkglib_DATA =
+nobase_dist_pkglib_DATA += xscale/debug_handler.bin 
+nobase_dist_pkglib_DATA += ecos/at91eb40a.elf
 
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)