drivers/jtag: rewrite usb_blaster driver
[openocd.git] / src / jtag / drivers / Makefile.am
index 134323d96fc2c7d0433f8587c64d36e66fbf617b..54361566283d87690c86120bbf7585b14e237920 100644 (file)
@@ -1,6 +1,7 @@
 include $(top_srcdir)/common.mk
 
 noinst_LTLIBRARIES = libocdjtagdrivers.la
+libocdjtagdrivers_la_LIBADD =
 
 libocdjtagdrivers_la_SOURCES = \
        $(DRIVERFILES)
@@ -13,6 +14,7 @@ ULINK_FIRMWARE = $(srcdir)/OpenULINK
 EXTRA_DIST = $(ULINK_FIRMWARE)
 
 DRIVERFILES =
+SUBDIRS=
 
 # Standard Driver: common files
 DRIVERFILES += driver.c
@@ -43,8 +45,12 @@ endif
 if FT2232_DRIVER
 DRIVERFILES += ft2232.c
 endif
+if FTDI_DRIVER
+DRIVERFILES += ftdi.c mpsse.c
+endif
 if USB_BLASTER_DRIVER
-DRIVERFILES += usb_blaster.c
+SUBDIRS += usb_blaster
+libocdjtagdrivers_la_LIBADD += $(top_builddir)/src/jtag/drivers/usb_blaster/libocdusbblaster.la
 endif
 if AMTJTAGACCEL
 DRIVERFILES += amt_jtagaccel.c
@@ -95,19 +101,38 @@ endif
 if REMOTE_BITBANG
 DRIVERFILES += remote_bitbang.c
 endif
-if STLINK
+if HLADAPTER
 DRIVERFILES += stlink_usb.c
+DRIVERFILES += ti_icdi_usb.c
+endif
+if OSBDM
+DRIVERFILES += osbdm.c
+endif
+if OPENDOUS
+DRIVERFILES += opendous.c
+endif
+if SYSFSGPIO
+DRIVERFILES += sysfsgpio.c
 endif
 
 noinst_HEADERS = \
        bitbang.h \
        bitq.h \
+       ftd2xx_common.h \
+       libusb0_common.h \
+       libusb1_common.h \
+       libusb_common.h \
        minidriver_imp.h \
+       mpsse.h \
        rlink.h \
        rlink_dtc_cmd.h \
        rlink_ep1_cmd.h \
        rlink_st7.h \
        usb_common.h \
-       stlink_usb.h
+       versaloon/usbtoxxx/usbtoxxx.h \
+       versaloon/usbtoxxx/usbtoxxx_internal.h \
+       versaloon/versaloon.h \
+       versaloon/versaloon_include.h \
+       versaloon/versaloon_internal.h
 
 MAINTAINERCLEANFILES = $(srcdir)/Makefile.in

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)