Add FTDI JTAG driver using MPSSE layer
[openocd.git] / src / jtag / drivers / Makefile.am
index 459027f99b495dce87111215b76cc046ec196479..0ce06ee3b30cc33615b9005f25f22369ff336cde 100644 (file)
@@ -43,6 +43,9 @@ endif
 if FT2232_DRIVER
 DRIVERFILES += ft2232.c
 endif
+if FTDI_DRIVER
+DRIVERFILES += ftdi.c mpsse.c
+endif
 if USB_BLASTER_DRIVER
 DRIVERFILES += usb_blaster.c
 endif
@@ -101,6 +104,9 @@ endif
 if OSBDM
 DRIVERFILES += osbdm.c
 endif
+if OPENDOUS
+DRIVERFILES += opendous.c
+endif
 
 noinst_HEADERS = \
        bitbang.h \
@@ -110,7 +116,6 @@ noinst_HEADERS = \
        rlink_dtc_cmd.h \
        rlink_ep1_cmd.h \
        rlink_st7.h \
-       usb_common.h \
-       stlink_usb.h
+       usb_common.h
 
 MAINTAINERCLEANFILES = $(srcdir)/Makefile.in

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)