libusb: require pkg-config support
[openocd.git] / src / helper / Makefile.am
index afe26b8106b53d274306c21cd38c629208c1c590..215bbaed5fbe72bc4efe0d7dcb6d59b791f5d835 100644 (file)
@@ -1,47 +1,61 @@
-AM_CPPFLAGS = \
-       -I$(top_srcdir)/src/server \
-       -I$(top_srcdir)/src/target \
-       -DPKGDATADIR=\"$(pkgdatadir)\" \
-       -DPKGLIBDIR=\"$(pkglibdir)\"
+include $(top_srcdir)/common.mk
 
 METASOURCES = AUTO
-noinst_LIBRARIES = libhelper.a
-
-if ECOSBOARD
-CONFIGFILES = 
-else
-CONFIGFILES = options.c jim.c jim-eventloop.c 
-endif
+noinst_LTLIBRARIES = libhelper.la
 
+CONFIGFILES = options.c time_support_common.c
 
+libhelper_la_CPPFLAGS = $(AM_CPPFLAGS) $(LIBUSB1_CFLAGS)
 
-libhelper_a_SOURCES = \
-       binarybuffer.c $(CONFIGFILES) configuration.c \
-       log.c command.c time_support.c \
-       replacements.c fileio.c startup_tcl.c
+libhelper_la_SOURCES = \
+       binarybuffer.c \
+       $(CONFIGFILES) \
+       configuration.c \
+       log.c \
+       command.c \
+       time_support.c \
+       replacements.c \
+       fileio.c \
+       util.c \
+       jim-nvp.c
 
 if IOUTIL
-libhelper_a_SOURCES += ioutil.c
+libhelper_la_SOURCES += ioutil.c
+else
+libhelper_la_SOURCES += ioutil_stubs.c
 endif
 
-libhelper_a_CFLAGS =
+libhelper_la_CFLAGS =
 if IS_MINGW
 # FD_* macros are sloppy with their signs on MinGW32 platform
-libhelper_a_CFLAGS += -Wno-sign-compare
+libhelper_la_CFLAGS += -Wno-sign-compare
 endif
 
-noinst_HEADERS = binarybuffer.h configuration.h types.h log.h command.h \
-       time_support.h replacements.h fileio.h jim.h jim-eventloop.h \
-       startup.tcl bin2char.c
-
-bin2char$(EXEEXT_FOR_BUILD): bin2char.c
+noinst_HEADERS = \
+       binarybuffer.h \
+       configuration.h \
+       ioutil.h \
+       list.h \
+       util.h \
+       types.h \
+       log.h \
+       command.h \
+       time_support.h \
+       replacements.h \
+       fileio.h \
+       system.h \
+       bin2char.c \
+       jim-nvp.h
+
+EXTRA_DIST = startup.tcl
+
+BIN2C = bin2char$(EXEEXT_FOR_BUILD)
+
+BUILT_SOURCES = $(BIN2C)
+
+$(BIN2C): bin2char.c
        ${CC_FOR_BUILD} ${CFLAGS_FOR_BUILD} $(srcdir)/bin2char.c -o $@
 
-# Convert .tcl to cfile
-startup_tcl.c: startup.tcl bin2char$(EXEEXT_FOR_BUILD)
-       ./bin2char$(EXEEXT_FOR_BUILD) startup_tcl < $(srcdir)/startup.tcl > $@
-
-# add startup_tcl.c to make clean list
-CLEANFILES = startup_tcl.c bin2char$(EXEEXT_FOR_BUILD)
+CLEANFILES = bin2char$(EXEEXT_FOR_BUILD)
 
-MAINTAINERCLEANFILES = Makefile.in
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)