Convert to non-recursive make
[openocd.git] / src / flash / nor / Makefile.am
index 1be84becfa3508f33eb49e53867862f6d779cdd9..727e4f2fa7c6aee882e5cd70b71634435fd7983e 100644 (file)
@@ -1,47 +1,66 @@
-AM_CPPFLAGS = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/helper \
-       -I$(top_srcdir)/src/jtag \
-       -I$(top_srcdir)/src/flash \
-       -I$(top_srcdir)/src/target
+noinst_LTLIBRARIES += %D%/libocdflashnor.la
+%C%_libocdflashnor_la_SOURCES = \
+       %D%/core.c \
+       %D%/tcl.c \
+       $(NOR_DRIVERS) \
+       %D%/drivers.c \
+       $(NORHEADERS)
 
-noinst_LTLIBRARIES = libocdflashnor.la
-libocdflashnor_la_SOURCES = \
-       aduc702x.c \
-       at91sam3.c \
-       at91sam7.c \
-       avrf.c \
-       cfi.c \
-       ecos.c \
-       faux.c \
-       lpc2000.c \
-       lpc288x.c \
-       lpc2900.c \
-       non_cfi.c \
-       ocl.c \
-       pic32mx.c \
-       stellaris.c \
-       stm32x.c \
-       str7x.c \
-       str9x.c \
-       str9xpec.c \
-       tms470.c
+NOR_DRIVERS = \
+       %D%/aduc702x.c \
+       %D%/aducm360.c \
+       %D%/ambiqmicro.c \
+       %D%/at91sam4.c \
+       %D%/at91sam4l.c \
+       %D%/at91samd.c \
+       %D%/at91sam3.c \
+       %D%/at91sam7.c \
+       %D%/atsamv.c \
+       %D%/avrf.c \
+       %D%/cfi.c \
+       %D%/dsp5680xx_flash.c \
+       %D%/efm32.c \
+       %D%/em357.c \
+       %D%/faux.c \
+       %D%/fm3.c \
+       %D%/fm4.c \
+       %D%/jtagspi.c \
+       %D%/kinetis.c \
+       %D%/kinetis_ke.c \
+       %D%/lpc2000.c \
+       %D%/lpc288x.c \
+       %D%/lpc2900.c \
+       %D%/lpcspifi.c \
+       %D%/mdr.c \
+       %D%/mrvlqspi.c \
+       %D%/niietcm4.c \
+       %D%/non_cfi.c \
+       %D%/nrf51.c \
+       %D%/numicro.c \
+       %D%/ocl.c \
+       %D%/pic32mx.c \
+       %D%/psoc4.c \
+       %D%/sim3x.c \
+       %D%/spi.c \
+       %D%/stmsmi.c \
+       %D%/stellaris.c \
+       %D%/stm32f1x.c \
+       %D%/stm32f2x.c \
+       %D%/stm32lx.c \
+       %D%/stm32l4x.c \
+       %D%/str7x.c \
+       %D%/str9x.c \
+       %D%/str9xpec.c \
+       %D%/tms470.c \
+       %D%/virtual.c \
+       %D%/xmc1xxx.c \
+       %D%/xmc4xxx.c
 
-noinst_HEADERS = \
-       at91sam7.h \
-       at91sam3.h \
-       avrf.h \
-       cfi.h \
-       lpc2000.h \
-       lpc288x.h \
-       non_cfi.h \
-       ocl.h \
-       pic32mx.h \
-       stellaris.h \
-       stm32x.h \
-       str7x.h \
-       str9x.h \
-       str9xpec.h \
-       tms470.h
-
-MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+NORHEADERS = \
+       %D%/core.h \
+       %D%/cfi.h \
+       %D%/driver.h \
+       %D%/imp.h \
+       %D%/non_cfi.h \
+       %D%/ocl.h \
+       %D%/spi.h

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)