mdr32fx: support for Milandr's MDR32Fx internal flash memory
[openocd.git] / src / flash / nor / Makefile.am
index 5d0a4dfcb1a25789e274657244ae9a07b054f420..080b847470f33542cc79a1cd77c6fe776ef64329 100644 (file)
@@ -1,6 +1,4 @@
-AM_CPPFLAGS = \
-       -I$(top_srcdir)/src \
-       -I$(top_builddir)/src
+include $(top_srcdir)/common.mk
 
 noinst_LTLIBRARIES = libocdflashnor.la
 libocdflashnor_la_SOURCES = \
@@ -11,43 +9,44 @@ libocdflashnor_la_SOURCES = \
 
 NOR_DRIVERS = \
        aduc702x.c \
+       at91sam4.c \
        at91sam3.c \
        at91sam7.c \
        avrf.c \
        cfi.c \
-       ecos.c \
+       efm32.c \
+       em357.c \
        faux.c \
        lpc2000.c \
        lpc288x.c \
        lpc2900.c \
+       lpcspifi.c \
+       mdr.c \
        non_cfi.c \
        ocl.c \
        pic32mx.c \
+       spi.c \
+       stmsmi.c \
        stellaris.c \
-       stm32x.c \
+       stm32f1x.c \
+       stm32f2x.c \
+       stm32lx.c \
        str7x.c \
        str9x.c \
        str9xpec.c \
-       tms470.c
+       tms470.c \
+       virtual.c \
+       fm3.c \
+       dsp5680xx_flash.c \
+       kinetis.c
 
 noinst_HEADERS = \
-       at91sam7.h \
-       at91sam3.h \
-       avrf.h \
        core.h \
        cfi.h \
        driver.h \
        imp.h \
-       lpc2000.h \
-       lpc288x.h \
        non_cfi.h \
        ocl.h \
-       pic32mx.h \
-       stellaris.h \
-       stm32x.h \
-       str7x.h \
-       str9x.h \
-       str9xpec.h \
-       tms470.h
+       spi.h
 
 MAINTAINERCLEANFILES = $(srcdir)/Makefile.in

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)