Convert to non-recursive make
[openocd.git] / src / flash / nand / Makefile.am
index 2ddd096ae98722fee9d846df3cc4b920558f9d9e..abe90f8bb830870be3ecd7fc39139d46ecd6913a 100644 (file)
@@ -1,46 +1,43 @@
-include $(top_srcdir)/common.mk
+noinst_LTLIBRARIES += %D%/libocdflashnand.la
 
-noinst_LTLIBRARIES = libocdflashnand.la
-
-libocdflashnand_la_SOURCES = \
-       ecc.c \
-       ecc_kw.c \
-       core.c \
-       fileio.c \
-       tcl.c \
-       arm_io.c \
+%C%_libocdflashnand_la_SOURCES = \
+       %D%/ecc.c \
+       %D%/ecc_kw.c \
+       %D%/core.c \
+       %D%/fileio.c \
+       %D%/tcl.c \
+       %D%/arm_io.c \
        $(NAND_DRIVERS) \
-       driver.c
+       %D%/driver.c \
+       $(NANDHEADERS)
 
 NAND_DRIVERS = \
-       nonce.c \
-       davinci.c \
-       lpc3180.c \
-       lpc32xx.c \
-       mxc.c \
-       mx3.c \
-       orion.c \
-       s3c24xx.c \
-       s3c2410.c \
-       s3c2412.c \
-       s3c2440.c \
-       s3c2443.c \
-       s3c6400.c \
-       at91sam9.c \
-       nuc910.c
-
-noinst_HEADERS = \
-       arm_io.h \
-       core.h \
-       driver.h \
-       fileio.h \
-       imp.h \
-       lpc3180.h \
-       lpc32xx.h \
-       mxc.h \
-       mx3.h \
-       s3c24xx.h \
-       s3c24xx_regs.h \
-       nuc910.h
+       %D%/nonce.c \
+       %D%/davinci.c \
+       %D%/lpc3180.c \
+       %D%/lpc32xx.c \
+       %D%/mxc.c \
+       %D%/mx3.c \
+       %D%/orion.c \
+       %D%/s3c24xx.c \
+       %D%/s3c2410.c \
+       %D%/s3c2412.c \
+       %D%/s3c2440.c \
+       %D%/s3c2443.c \
+       %D%/s3c6400.c \
+       %D%/at91sam9.c \
+       %D%/nuc910.c
 
-MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+NANDHEADERS = \
+       %D%/arm_io.h \
+       %D%/core.h \
+       %D%/driver.h \
+       %D%/fileio.h \
+       %D%/imp.h \
+       %D%/lpc3180.h \
+       %D%/lpc32xx.h \
+       %D%/mxc.h \
+       %D%/mx3.h \
+       %D%/s3c24xx.h \
+       %D%/s3c24xx_regs.h \
+       %D%/nuc910.h

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)