Remove support for the GPL incompatible FTDI D2XX library
[openocd.git] / src / Makefile.am
index 203375209206002baf33d9829bd2af2109897aec..fe403366ad24a68b584f97e00c728e63337f9a7b 100644 (file)
@@ -1,47 +1,53 @@
-SUBDIRS = helper jtag xsvf svf target server flash pld
-
-lib_LTLIBRARIES = libopenocd.la
+include $(top_srcdir)/common.mk
+
+SUBDIRS = \
+       jtag \
+       helper \
+       target \
+       transport \
+       flash \
+       svf \
+       xsvf \
+       pld \
+       server \
+       rtos
+
+noinst_LTLIBRARIES = libopenocd.la
 bin_PROGRAMS = openocd
 
-if ECOSBOARD
-MAINFILE = ecosboard.c
-else
 MAINFILE = main.c
-endif
 
 openocd_SOURCES = $(MAINFILE)
 openocd_LDADD = libopenocd.la
 
+if INTERNAL_JIMTCL
+openocd_LDADD += $(top_builddir)/jimtcl/libjim.a
+else
+openocd_LDADD += -ljim
+endif
+
+if ULINK
+openocd_LDADD += -lm
+endif
+
 libopenocd_la_SOURCES = \
        hello.c \
-       openocd.c \
-       startup_tcl.c
+       openocd.c
 
 noinst_HEADERS = \
        hello.h \
        openocd.h
 
-
-# set the include path found by configure
-AM_CPPFLAGS = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/helper \
-       -I$(top_srcdir)/src/jtag \
-       -I$(top_srcdir)/src/target \
-       -I$(top_srcdir)/src/xsvf \
-       -I$(top_srcdir)/src/svf \
-       -I$(top_srcdir)/src/server \
-       -I$(top_srcdir)/src/flash \
-       -I$(top_srcdir)/src/pld
-
 libopenocd_la_CPPFLAGS = -DPKGBLDDATE=\"`date +%F-%R`\"
 
 # banner output includes RELSTR appended to $VERSION from the configure script
 # guess-rev.sh returns either a repository version ID or "-snapshot"
 if RELEASE
 libopenocd_la_CPPFLAGS += -DRELSTR=\"\"
+libopenocd_la_CPPFLAGS += -DGITVERSION=\"\"
 else
 libopenocd_la_CPPFLAGS += -DRELSTR=\"`$(top_srcdir)/guess-rev.sh $(top_srcdir)`\"
+libopenocd_la_CPPFLAGS += -DGITVERSION=\"`cd $(top_srcdir) && git describe`\"
 endif
 
 # add default CPPFLAGS
@@ -56,47 +62,22 @@ else
 MINGWLDADD =
 endif
 
-if FT2232_LIBFTDI
-FTDI2232LIB = -lftdi -lusb
-else
-if PRESTO_LIBFTDI
-FTDI2232LIB = -lftdi -lusb
-else
-FTDI2232LIB =
-endif
-endif
-
-if USBPROG
-LIBUSB = -lusb
-else
-if JLINK
-LIBUSB = -lusb
-else
-if RLINK
-LIBUSB = -lusb
-else
-if VSLLINK
-LIBUSB = -lusb
-else
-LIBUSB =
-endif
-endif
-endif
-endif
-
 libopenocd_la_LIBADD = \
        $(top_builddir)/src/xsvf/libxsvf.la \
        $(top_builddir)/src/svf/libsvf.la \
        $(top_builddir)/src/pld/libpld.la \
        $(top_builddir)/src/jtag/libjtag.la \
+       $(top_builddir)/src/transport/libtransport.la \
        $(top_builddir)/src/flash/libflash.la \
        $(top_builddir)/src/target/libtarget.la \
        $(top_builddir)/src/server/libserver.la \
+       $(top_builddir)/src/rtos/librtos.la \
        $(top_builddir)/src/helper/libhelper.la \
-       $(FTDI2232LIB) $(MINGWLDADD) $(LIBUSB)
+       $(LIBFTDI_LIBS) $(MINGWLDADD) \
+       $(HIDAPI_LIBS) $(LIBUSB0_LIBS) $(LIBUSB1_LIBS)
 
-if HTTPD
-libopenocd_la_LIBADD += -lmicrohttpd
+if !INTERNAL_LIBJAYLINK
+libopenocd_la_LIBADD += $(libjaylink_LIBS)
 endif
 
 STARTUP_TCL_SRCS = \
@@ -108,20 +89,23 @@ STARTUP_TCL_SRCS = \
 
 EXTRA_DIST = $(STARTUP_TCL_SRCS)
 
-BUILT_SOURCES = startup.tcl
+BUILT_SOURCES = startup_tcl.inc
 
 startup.tcl: $(STARTUP_TCL_SRCS)
        cat $^ > $@
 
-BIN2C = $(top_builddir)/src/helper/bin2char$(EXEEXT_FOR_BUILD)
+BIN2C = $(top_srcdir)/src/helper/bin2char.sh
 
-# Convert .tcl to cfile
-startup_tcl.c: startup.tcl $(BIN2C)
-       $(BIN2C) openocd_startup_tcl < $< > $@ || rm -f $@
+# Convert .tcl to c-array
+startup_tcl.inc: startup.tcl $(BIN2C)
+       $(BIN2C) < $< > $@ || { rm -f $@; false; }
 
-# add startup_tcl.c to make clean list
-CLEANFILES = startup.tcl startup_tcl.c
+# add generated files to make clean list
+CLEANFILES = startup.tcl startup_tcl.inc
 
+# we do not want generated file in the dist
+dist-hook:
+       rm -f $(distdir)/startup_tcl.inc
 
 MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
 

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)