jtag: usb_blaster: fix allocation of usb_blaster_device_desc
[openocd.git] / src / Makefile.am
index 2f17ba4df4330d52bc4fb8705aa641d8b3b1cc8a..c78e81c801fb48324a30578460b0e21104b1ab3a 100644 (file)
@@ -1,46 +1,54 @@
-SUBDIRS = helper jtag xsvf svf target server flash pld
+include $(top_srcdir)/common.mk
+
+SUBDIRS = \
+       jtag \
+       helper \
+       target \
+       transport \
+       flash \
+       svf \
+       xsvf \
+       pld \
+       server \
+       rtos
 
 lib_LTLIBRARIES = libopenocd.la
 bin_PROGRAMS = openocd
 
-if ECOSBOARD
-MAINFILE = ecosboard.c
-else
 MAINFILE = main.c
-endif
 
 openocd_SOURCES = $(MAINFILE)
 openocd_LDADD = libopenocd.la
 
+if INTERNAL_JIMTCL
+openocd_LDADD += $(top_builddir)/jimtcl/libjim.a
+else
+openocd_LDADD += -ljim
+endif
+
+if ULINK
+openocd_LDADD += -lm
+endif
+
 libopenocd_la_SOURCES = \
        hello.c \
        openocd.c \
        startup_tcl.c
 
 noinst_HEADERS = \
+       hello.h \
        openocd.h
 
-
-# set the include path found by configure
-AM_CPPFLAGS = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/helper \
-       -I$(top_srcdir)/src/jtag \
-       -I$(top_srcdir)/src/target \
-       -I$(top_srcdir)/src/xsvf \
-       -I$(top_srcdir)/src/svf \
-       -I$(top_srcdir)/src/server \
-       -I$(top_srcdir)/src/flash \
-       -I$(top_srcdir)/src/pld
-
 libopenocd_la_CPPFLAGS = -DPKGBLDDATE=\"`date +%F-%R`\"
 
 # banner output includes RELSTR appended to $VERSION from the configure script
 # guess-rev.sh returns either a repository version ID or "-snapshot"
 if RELEASE
 libopenocd_la_CPPFLAGS += -DRELSTR=\"\"
+libopenocd_la_CPPFLAGS += -DGITVERSION=\"\"
 else
 libopenocd_la_CPPFLAGS += -DRELSTR=\"`$(top_srcdir)/guess-rev.sh $(top_srcdir)`\"
+libopenocd_la_CPPFLAGS += -DGITVERSION=\"`cd $(top_srcdir) && git describe`\"
 endif
 
 # add default CPPFLAGS
@@ -58,29 +66,24 @@ endif
 if FT2232_LIBFTDI
 FTDI2232LIB = -lftdi -lusb
 else
+if USB_BLASTER_LIBFTDI
+FTDI2232LIB = -lftdi -lusb
+else
 if PRESTO_LIBFTDI
 FTDI2232LIB = -lftdi -lusb
 else
 FTDI2232LIB =
 endif
 endif
+endif
 
-if USBPROG
-LIBUSB = -lusb
-else
-if JLINK
-LIBUSB = -lusb
-else
-if RLINK
-LIBUSB = -lusb
-else
-if VSLLINK
-LIBUSB = -lusb
-else
 LIBUSB =
+if USE_LIBUSB1
+LIBUSB += -lusb-1.0
 endif
-endif
-endif
+
+if USE_LIBUSB0
+LIBUSB += -lusb
 endif
 
 libopenocd_la_LIBADD = \
@@ -88,18 +91,20 @@ libopenocd_la_LIBADD = \
        $(top_builddir)/src/svf/libsvf.la \
        $(top_builddir)/src/pld/libpld.la \
        $(top_builddir)/src/jtag/libjtag.la \
+       $(top_builddir)/src/transport/libtransport.la \
        $(top_builddir)/src/flash/libflash.la \
        $(top_builddir)/src/target/libtarget.la \
        $(top_builddir)/src/server/libserver.la \
+       $(top_builddir)/src/rtos/librtos.la \
        $(top_builddir)/src/helper/libhelper.la \
        $(FTDI2232LIB) $(MINGWLDADD) $(LIBUSB)
 
-if HTTPD
-libopenocd_la_LIBADD += -lmicrohttpd
-endif
-
 STARTUP_TCL_SRCS = \
-       $(srcdir)/helper/startup.tcl
+       $(srcdir)/helper/startup.tcl \
+       $(srcdir)/jtag/startup.tcl \
+       $(srcdir)/target/startup.tcl \
+       $(srcdir)/flash/startup.tcl \
+       $(srcdir)/server/startup.tcl
 
 EXTRA_DIST = $(STARTUP_TCL_SRCS)
 
@@ -108,16 +113,19 @@ BUILT_SOURCES = startup.tcl
 startup.tcl: $(STARTUP_TCL_SRCS)
        cat $^ > $@
 
-BIN2C = $(builddir)/helper/bin2char$(EXEEXT_FOR_BUILD)
+BIN2C = $(top_builddir)/src/helper/bin2char$(EXEEXT_FOR_BUILD)
 
 # Convert .tcl to cfile
 startup_tcl.c: startup.tcl $(BIN2C)
-       $(BIN2C) startup_tcl < $< > $@ || rm -f $@
+       $(BIN2C) openocd_startup_tcl < $< > $@ || rm -f $@
 
 # add startup_tcl.c to make clean list
 CLEANFILES = startup.tcl startup_tcl.c
 
-
+# we do not want generated file in the dist
+dist-hook:
+       rm -f $(distdir)/startup_tcl.c
+       
 MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
 
 # The "quick" target builds executables & reinstalls the executables

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)