wi-9c target scripts
[openocd.git] / src / Makefile.am
index 6e72a61228462f1cc7f6a36f66b76c3c25ac1f6f..aa3155062173c0106897d21b0d3bd0c9c77eaec9 100644 (file)
@@ -6,6 +6,13 @@ INCLUDES = -I$(top_srcdir)/src/helper \
        -I$(top_srcdir)/src/jtag -I$(top_srcdir)/src/target -I$(top_srcdir)/src/xsvf -I$(top_srcdir)/src/server \
        -I$(top_srcdir)/src/flash -I$(top_srcdir)/src/pld $(all_includes)
 
+# pass path to prefix path
+openocd_CPPFLAGS = \
+ -DPKGLIBDIR=\"$(pkglibdir)\" \
+ -DPKGBLDDATE=\"`date +%F-%R`\" \
+ -DPKGBLDREV=\"`$(top_srcdir)/guess-rev.sh`\" \
+ @CPPFLAGS@
+
 # the library search path.
 openocd_LDFLAGS = $(all_libraries) 
 SUBDIRS = helper jtag xsvf target server flash pld
@@ -21,9 +28,10 @@ FTDI2232LIB = -lftdi
 else
 if PRESTO_LIBFTDI
 FTDI2232LIB = -lftdi
-endif
+else
 FTDI2232LIB =
 endif
+endif
 
 if USBPROG
 LIBUSB = -lusb

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)