Dick Hollenbeck <dick@softplc.com> moved stuff into openocd.c - should never have...
[openocd.git] / src / Makefile.am
index 1103e57511088b77baf9b9cb7b12165a98507dbf..a49957948e269f12eee4c65008e161de576a4509 100644 (file)
@@ -6,7 +6,6 @@ else
 MAINFILE = main.c
 endif
 
-
 openocd_SOURCES = $(MAINFILE) openocd.c
 
 # set the include path found by configure
@@ -17,9 +16,16 @@ INCLUDES = -I$(top_srcdir)/src -I$(top_srcdir)/src/helper \
 # pass path to prefix path
 openocd_CPPFLAGS = \
  -DPKGLIBDIR=\"$(pkglibdir)\" \
- -DPKGBLDDATE=\"`date +%F-%R`\" \
- -DPKGBLDREV=\"`$(top_srcdir)/guess-rev.sh`\" \
- @CPPFLAGS@
+ -DPKGBLDDATE=\"`date +%F-%R`\"
+
+if RELEASE
+openocd_CPPFLAGS += -DRELSTR=\"Release\" -DPKGBLDREV=\"\"
+else
+openocd_CPPFLAGS += -DRELSTR=\"svn:\" -DPKGBLDREV=\"`$(top_srcdir)/guess-rev.sh $(top_srcdir)`\"
+endif
+
+# add default CPPFLAGS
+openocd_CPPFLAGS += @CPPFLAGS@
 
 # the library search path.
 openocd_LDFLAGS = $(all_libraries) 
@@ -59,8 +65,6 @@ endif
 endif
 endif
 
-
-
 openocd_LDADD = $(top_builddir)/src/xsvf/libxsvf.a $(top_builddir)/src/svf/libsvf.a \
        $(top_builddir)/src/target/libtarget.a $(top_builddir)/src/jtag/libjtag.a \
        $(top_builddir)/src/helper/libhelper.a \
@@ -69,13 +73,10 @@ openocd_LDADD = $(top_builddir)/src/xsvf/libxsvf.a $(top_builddir)/src/svf/libsv
        $(top_builddir)/src/pld/libpld.a \
        $(FTDI2232LIB) $(MINGWLDADD) $(LIBUSB)
 
-
 if HTTPD
 openocd_LDADD += -lmicrohttpd
 endif
 
-
-
 nobase_dist_pkglib_DATA = \
        tcl/bitsbytes.tcl                       \
        tcl/chip/atmel/at91/aic.tcl             \

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)