cmsis-dap: add initial cmsis-dap support
[openocd.git] / src / Makefile.am
index c78e81c801fb48324a30578460b0e21104b1ab3a..5e9c850996425ba3c1a91765fbac5cf1293f1808 100644 (file)
@@ -12,7 +12,7 @@ SUBDIRS = \
        server \
        rtos
 
-lib_LTLIBRARIES = libopenocd.la
+noinst_LTLIBRARIES = libopenocd.la
 bin_PROGRAMS = openocd
 
 MAINFILE = main.c
@@ -52,7 +52,7 @@ libopenocd_la_CPPFLAGS += -DGITVERSION=\"`cd $(top_srcdir) && git describe`\"
 endif
 
 # add default CPPFLAGS
-libopenocd_la_CPPFLAGS += $(AM_CPPFLAGS) $(CPPFLAGS)
+libopenocd_la_CPPFLAGS += $(AM_CPPFLAGS) $(CPPFLAGS) $(LIBFTDI_CFLAGS)
 
 # the library search path.
 libopenocd_la_LDFLAGS = $(all_libraries)
@@ -63,29 +63,6 @@ else
 MINGWLDADD =
 endif
 
-if FT2232_LIBFTDI
-FTDI2232LIB = -lftdi -lusb
-else
-if USB_BLASTER_LIBFTDI
-FTDI2232LIB = -lftdi -lusb
-else
-if PRESTO_LIBFTDI
-FTDI2232LIB = -lftdi -lusb
-else
-FTDI2232LIB =
-endif
-endif
-endif
-
-LIBUSB =
-if USE_LIBUSB1
-LIBUSB += -lusb-1.0
-endif
-
-if USE_LIBUSB0
-LIBUSB += -lusb
-endif
-
 libopenocd_la_LIBADD = \
        $(top_builddir)/src/xsvf/libxsvf.la \
        $(top_builddir)/src/svf/libsvf.la \
@@ -97,7 +74,8 @@ libopenocd_la_LIBADD = \
        $(top_builddir)/src/server/libserver.la \
        $(top_builddir)/src/rtos/librtos.la \
        $(top_builddir)/src/helper/libhelper.la \
-       $(FTDI2232LIB) $(MINGWLDADD) $(LIBUSB)
+       $(LIBFTDI_LIBS) $(MINGWLDADD) \
+       $(HIDAPI_LIBS) $(LIBUSB1_LIBS) $(LIBUSB0_LIBS)
 
 STARTUP_TCL_SRCS = \
        $(srcdir)/helper/startup.tcl \
@@ -125,7 +103,7 @@ CLEANFILES = startup.tcl startup_tcl.c
 # we do not want generated file in the dist
 dist-hook:
        rm -f $(distdir)/startup_tcl.c
-       
+
 MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
 
 # The "quick" target builds executables & reinstalls the executables

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)