build: cleanup src/server directory
[openocd.git] / src / Makefile.am
index 0cb13ab6fb1127ed2b3ed97b54221fd14373e25c..3a92fffee3c43bd426a6f22c1001449fef026d7e 100644 (file)
@@ -1,33 +1,68 @@
-bin_PROGRAMS = openocd bin2char
+include $(top_srcdir)/common.mk
 
-bin2char_SOURCES = bin2char.c
+SUBDIRS = \
+       jtag \
+       helper \
+       target \
+       transport \
+       flash \
+       svf \
+       xsvf \
+       pld \
+       server \
+       rtos
+
+lib_LTLIBRARIES = libopenocd.la
+bin_PROGRAMS = openocd
 
 if ECOSBOARD
 MAINFILE = ecosboard.c
 else
-MAINFILE = main.c jim.c
+MAINFILE = main.c
 endif
 
-openocd_SOURCES = $(MAINFILE) openocd.c startup_tcl.c
+openocd_SOURCES = $(MAINFILE)
+openocd_LDADD = libopenocd.la
 
-# set the include path found by configure
-INCLUDES = -I$(top_srcdir)/src -I$(top_srcdir)/src/helper \
-       -I$(top_srcdir)/src/jtag -I$(top_srcdir)/src/target -I$(top_srcdir)/src/xsvf -I$(top_srcdir)/src/server \
-       -I$(top_srcdir)/src/flash -I$(top_srcdir)/src/pld $(all_includes)
+if INTERNAL_JIMTCL
+openocd_LDADD += $(top_builddir)/jimtcl/libjim.a
+else
+openocd_LDADD += -ljim
+endif
+
+if ULINK
+openocd_LDADD += -lm
+endif
 
-# pass path to prefix path
-openocd_CPPFLAGS = \
- -DPKGLIBDIR=\"$(pkglibdir)\" \
- -DPKGBLDDATE=\"`date +%F-%R`\" \
- -DPKGBLDREV=\"`$(top_srcdir)/guess-rev.sh`\" \
- @CPPFLAGS@
+libopenocd_la_SOURCES = \
+       hello.c \
+       openocd.c \
+       startup_tcl.c
+
+noinst_HEADERS = \
+       hello.h \
+       openocd.h
+
+libopenocd_la_CPPFLAGS = -DPKGBLDDATE=\"`date +%F-%R`\"
+
+# banner output includes RELSTR appended to $VERSION from the configure script
+# guess-rev.sh returns either a repository version ID or "-snapshot"
+if RELEASE
+libopenocd_la_CPPFLAGS += -DRELSTR=\"\"
+libopenocd_la_CPPFLAGS += -DGITVERSION=\"\"
+else
+libopenocd_la_CPPFLAGS += -DRELSTR=\"`$(top_srcdir)/guess-rev.sh $(top_srcdir)`\"
+libopenocd_la_CPPFLAGS += -DGITVERSION=\"`cd $(top_srcdir) && git describe`\"
+endif
+
+# add default CPPFLAGS
+libopenocd_la_CPPFLAGS += $(AM_CPPFLAGS) $(CPPFLAGS)
 
 # the library search path.
-openocd_LDFLAGS = $(all_libraries) 
-SUBDIRS = helper jtag xsvf target server flash pld
+libopenocd_la_LDFLAGS = $(all_libraries)
 
 if IS_MINGW
-MINGWLDADD = -lwsock32
+MINGWLDADD = -lws2_32
 else
 MINGWLDADD =
 endif
@@ -35,67 +70,74 @@ endif
 if FT2232_LIBFTDI
 FTDI2232LIB = -lftdi -lusb
 else
+if USB_BLASTER_LIBFTDI
+FTDI2232LIB = -lftdi -lusb
+else
 if PRESTO_LIBFTDI
 FTDI2232LIB = -lftdi -lusb
 else
 FTDI2232LIB =
 endif
 endif
+endif
 
-if USBPROG
-LIBUSB = -lusb
-else
-if JLINK
-LIBUSB = -lusb
-else
 LIBUSB =
-endif
+if USE_LIBUSB1
+LIBUSB += -lusb-1.0
 endif
 
-if IS_WIN32
-if FTD2XXDIR
-FTD2XXLDADD = @WITH_FTD2XX@/FTD2XX.lib
-else
-FTD2XXLDADD = -lftd2xx
-endif
-else
-FTD2XXLDADD = -lftd2xx 
-endif
-  
-if FT2232_FTD2XX
-FTD2XXLIB = $(FTD2XXLDADD)
-else
-if PRESTO_FTD2XX
-FTD2XXLIB = $(FTD2XXLDADD)
-else
-FTD2XXLIB =
-endif
+if USE_LIBUSB0
+LIBUSB += -lusb
 endif
 
-openocd_LDADD = $(top_builddir)/src/xsvf/libxsvf.a \
-       $(top_builddir)/src/target/libtarget.a $(top_builddir)/src/jtag/libjtag.a \
-       $(top_builddir)/src/helper/libhelper.a \
-       $(top_builddir)/src/server/libserver.a $(top_builddir)/src/helper/libhelper.a \
-       $(top_builddir)/src/flash/libflash.a $(top_builddir)/src/target/libtarget.a \
-       $(top_builddir)/src/pld/libpld.a \
-       $(FTDI2232LIB) $(FTD2XXLIB) $(MINGWLDADD) $(LIBUSB)
-
-nobase_dist_pkglib_DATA = \
-       tcl/bitsbytes.tcl  \
-       tcl/chip/atmel/at91/aic.tcl  \
-       tcl/chip/atmel/at91/at91sam7x128.tcl  \
-       tcl/chip/atmel/at91/at91sam7x256.tcl  \
-       tcl/chip/atmel/at91/pmc.tcl  \
-       tcl/chip/atmel/at91/rtt.tcl  \
-       tcl/chip/atmel/at91/usarts.tcl  \
-       tcl/cpu/arm/arm7tdmi.tcl  \
-       tcl/cpu/arm/arm920.tcl  \
-       tcl/cpu/arm/arm946.tcl  \
-       tcl/cpu/arm/arm966.tcl  \
-       tcl/memory.tcl  \
-       tcl/mmr_helpers.tcl  \
-       tcl/readable.tcl  
+libopenocd_la_LIBADD = \
+       $(top_builddir)/src/xsvf/libxsvf.la \
+       $(top_builddir)/src/svf/libsvf.la \
+       $(top_builddir)/src/pld/libpld.la \
+       $(top_builddir)/src/jtag/libjtag.la \
+       $(top_builddir)/src/transport/libtransport.la \
+       $(top_builddir)/src/flash/libflash.la \
+       $(top_builddir)/src/target/libtarget.la \
+       $(top_builddir)/src/server/libserver.la \
+       $(top_builddir)/src/rtos/librtos.la \
+       $(top_builddir)/src/helper/libhelper.la \
+       $(FTDI2232LIB) $(MINGWLDADD) $(LIBUSB)
+
+STARTUP_TCL_SRCS = \
+       $(srcdir)/helper/startup.tcl \
+       $(srcdir)/jtag/startup.tcl \
+       $(srcdir)/target/startup.tcl \
+       $(srcdir)/flash/startup.tcl \
+       $(srcdir)/server/startup.tcl
+
+EXTRA_DIST = $(STARTUP_TCL_SRCS)
+
+BUILT_SOURCES = startup.tcl
+
+startup.tcl: $(STARTUP_TCL_SRCS)
+       cat $^ > $@
+
+BIN2C = $(top_builddir)/src/helper/bin2char$(EXEEXT_FOR_BUILD)
 
 # Convert .tcl to cfile
-startup_tcl.c: bin2char startup.tcl
-       ./bin2char startup_tcl < $(srcdir)/startup.tcl > startup_tcl.c
+startup_tcl.c: startup.tcl $(BIN2C)
+       $(BIN2C) openocd_startup_tcl < $< > $@ || rm -f $@
+
+# add startup_tcl.c to make clean list
+CLEANFILES = startup.tcl startup_tcl.c
+
+# we do not want generated file in the dist
+dist-hook:
+       rm -f $(distdir)/startup_tcl.c
+       
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+
+# The "quick" target builds executables & reinstalls the executables
+# Primary use: developer types to quicken the edit/compile/debug
+# cycle.  by not requiring a "full build and full install". Note the
+# assumption is: You are only rebuilding the EXE.... and everything
+# else is/was previously installed.
+#
+# use at your own risk
+quick: all install-binPROGRAMS
+

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)