armv7a_mmu: s/LOG_ERROR/LOG_WARNING/ on address translation failure
[openocd.git] / src / Makefile.am
index 793d020ae31b4acdb1d4390789c04d219f28dbb0..07981aa67ec2faea9f58fdd19d3081d9396b14c1 100644 (file)
@@ -1,96 +1,85 @@
-bin_PROGRAMS = openocd
+noinst_LTLIBRARIES += %D%/libopenocd.la
+bin_PROGRAMS += %D%/openocd
 
-if ECOSBOARD
-MAINFILE = ecosboard.c
+%C%_openocd_SOURCES = \
+       %D%/main.c
+
+%C%_libopenocd_la_SOURCES = \
+       %D%/hello.c %D%/hello.h \
+       %D%/openocd.c %D%/openocd.h
+
+%C%_openocd_LDADD = %D%/libopenocd.la
+
+%C%_openocd_LDADD += $(MINGWLDADD)
+
+if INTERNAL_JIMTCL
+%C%_openocd_LDADD += $(top_builddir)/jimtcl/libjim.a
 else
-MAINFILE = main.c
+%C%_openocd_LDADD += -ljim
 endif
 
-openocd_SOURCES = $(MAINFILE) openocd.c
+%C%_libopenocd_la_CPPFLAGS =
 
-# set the include path found by configure
-INCLUDES = -I$(top_srcdir)/src -I$(top_srcdir)/src/helper \
-       -I$(top_srcdir)/src/jtag -I$(top_srcdir)/src/target -I$(top_srcdir)/src/xsvf -I$(top_srcdir)/src/server \
-       -I$(top_srcdir)/src/flash -I$(top_srcdir)/src/pld $(all_includes)
+# banner output includes RELSTR appended to $VERSION from the configure script
+# guess-rev.sh returns either a repository version ID or "-snapshot"
+if RELEASE
+%C%_libopenocd_la_CPPFLAGS += -DRELSTR=\"\"
+%C%_libopenocd_la_CPPFLAGS += -DGITVERSION=\"\"
+else
+%C%_libopenocd_la_CPPFLAGS += -DRELSTR=\"`$(top_srcdir)/guess-rev.sh $(top_srcdir)`\"
+%C%_libopenocd_la_CPPFLAGS += -DGITVERSION=\"`cd $(top_srcdir) && git describe`\"
+%C%_libopenocd_la_CPPFLAGS += -DPKGBLDDATE=\"`date +%F-%R`\"
+endif
 
-# pass path to prefix path
-openocd_CPPFLAGS = \
- -DPKGLIBDIR=\"$(pkglibdir)\" \
- -DPKGBLDDATE=\"`date +%F-%R`\" \
- -DPKGBLDREV=\"`$(top_srcdir)/guess-rev.sh`\" \
- @CPPFLAGS@
+# add default CPPFLAGS
+%C%_libopenocd_la_CPPFLAGS += $(AM_CPPFLAGS) $(CPPFLAGS)
 
 # the library search path.
-openocd_LDFLAGS = $(all_libraries) 
-SUBDIRS = helper jtag xsvf target server flash pld
+%C%_libopenocd_la_LDFLAGS = $(all_libraries)
 
 if IS_MINGW
-MINGWLDADD = -lwsock32
+MINGWLDADD = -lws2_32
 else
 MINGWLDADD =
 endif
 
-if FT2232_LIBFTDI
-FTDI2232LIB = -lftdi -lusb
-else
-if PRESTO_LIBFTDI
-FTDI2232LIB = -lftdi -lusb
-else
-FTDI2232LIB =
-endif
-endif
+%C%_libopenocd_la_LIBADD = \
+       %D%/xsvf/libxsvf.la \
+       %D%/svf/libsvf.la \
+       %D%/pld/libpld.la \
+       %D%/jtag/libjtag.la \
+       %D%/transport/libtransport.la \
+       %D%/flash/libflash.la \
+       %D%/target/libtarget.la \
+       %D%/server/libserver.la \
+       %D%/rtos/librtos.la \
+       %D%/helper/libhelper.la
 
-if USBPROG
-LIBUSB = -lusb
-else
-if JLINK
-LIBUSB = -lusb
-else
-LIBUSB =
-endif
-endif
+BIN2C = $(srcdir)/%D%/helper/bin2char.sh
 
-if IS_WIN32
-if FTD2XXDIR
-FTD2XXLDADD = @WITH_FTD2XX@/FTD2XX.lib
-else
-FTD2XXLDADD = -lftd2xx
-endif
-else
-FTD2XXLDADD = -lftd2xx 
-endif
-  
-if FT2232_FTD2XX
-FTD2XXLIB = $(FTD2XXLDADD)
-else
-if PRESTO_FTD2XX
-FTD2XXLIB = $(FTD2XXLDADD)
-else
-FTD2XXLIB =
-endif
-endif
+STARTUP_TCL_SRCS =
+EXTRA_DIST += $(STARTUP_TCL_SRCS)
+
+BUILT_SOURCES += %D%/startup_tcl.inc
+
+# Convert .tcl to c-array
+%D%/startup_tcl.inc: $(STARTUP_TCL_SRCS)
+       cat $^ | $(BIN2C) > $@ || { rm -f $@; false; }
+
+# add generated files to make clean list
+CLEANFILES += %D%/startup_tcl.inc
 
-openocd_LDADD = $(top_builddir)/src/xsvf/libxsvf.a \
-       $(top_builddir)/src/target/libtarget.a $(top_builddir)/src/jtag/libjtag.a \
-       $(top_builddir)/src/helper/libhelper.a \
-       $(top_builddir)/src/server/libserver.a $(top_builddir)/src/helper/libhelper.a \
-       $(top_builddir)/src/flash/libflash.a $(top_builddir)/src/target/libtarget.a \
-       $(top_builddir)/src/pld/libpld.a \
-       $(FTDI2232LIB) $(FTD2XXLIB) $(MINGWLDADD) $(LIBUSB)
-
-nobase_dist_pkglib_DATA = \
-       tcl/bitsbytes.tcl  \
-       tcl/chip/atmel/at91/aic.tcl  \
-       tcl/chip/atmel/at91/at91sam7x128.tcl  \
-       tcl/chip/atmel/at91/at91sam7x256.tcl  \
-       tcl/chip/atmel/at91/pmc.tcl  \
-       tcl/chip/atmel/at91/rtt.tcl  \
-       tcl/chip/atmel/at91/usarts.tcl  \
-       tcl/cpu/arm/arm7tdmi.tcl  \
-       tcl/cpu/arm/arm920.tcl  \
-       tcl/cpu/arm/arm946.tcl  \
-       tcl/cpu/arm/arm966.tcl  \
-       tcl/memory.tcl  \
-       tcl/mmr_helpers.tcl  \
-       tcl/readable.tcl  
+# we do not want generated file in the dist
+#dist-hook:
+#      rm -f $(distdir)/%D%/startup_tcl.inc
 
+include %D%/helper/Makefile.am
+include %D%/jtag/Makefile.am
+include %D%/transport/Makefile.am
+include %D%/xsvf/Makefile.am
+include %D%/svf/Makefile.am
+include %D%/target/Makefile.am
+include %D%/rtos/Makefile.am
+include %D%/server/Makefile.am
+include %D%/flash/Makefile.am
+include %D%/pld/Makefile.am

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)