Convert to non-recursive make
[openocd.git] / doc / Makefile.am
index ce2d78d9d938a064b2f3ad8bf15efad94f44642c..67592038d50e3339ab74dfa0e1e6187a21af837c 100644 (file)
@@ -1,17 +1,11 @@
-info_TEXINFOS = openocd.texi
-openocd_TEXINFOS = fdl.texi
-man_MANS = openocd.1
-EXTRA_DIST = openocd.1
+info_TEXINFOS += %D%/openocd.texi
+%C%_openocd_TEXINFOS = %D%/fdl.texi
 
-dist-hook:
-       mkdir $(distdir)/manual
-       cp -p $(srcdir)/manual/*.txt $(distdir)/manual
-       for i in $$(cd $(srcdir)/manual/ && ls -d */); do \
-               mkdir $(distdir)/manual/$$i; \
-               cp -p $(srcdir)/manual/$$i/* $(distdir)/manual/$$i/; \
-       done
+dist_man_MANS += %D%/openocd.1
 
-MAINTAINERCLEANFILES = \
-       $(srcdir)/Makefile.in \
-       $(srcdir)/mdate-sh \
-       $(srcdir)/texinfo.tex
+EXTRA_DIST += %D%/manual
+
+MAINTAINERCLEANFILES += \
+       %D%/mdate-sh \
+       %D%/stamp-vti \
+       %D%/version.texi

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)