cortex_m3: use armv7m's async algorithm implementation
[openocd.git] / README
diff --git a/README b/README
index ba42d01..7c1b5b2 100644 (file)
--- a/README
+++ b/README
@@ -64,17 +64,23 @@ you can build the in-tree documentation.
 Installing OpenOCD
 ==================
 
+On Linux, you may have permissions problems to address.  The best way
+to do this is to use the contrib/openocd.udev rules file.  It probably
+belongs somewhere in /etc/udev/rules.d, but consult your operating
+system documentation to be sure.  In particular, make sure that it
+matches the syntax used by your operating system's version of udev.
+
 A Note to OpenOCD Users
 -----------------------
 
 If you would rather be working "with" OpenOCD rather than "on" it, your
-operating system or interface supplier may provide binaries for you in a
-convenient package.
+operating system or JTAG interface supplier may provide binaries for
+you in a convenient-enough package.
 
-Such packages should be more stable than SVN trunk, where bleeding-edge
+Such packages may be more stable than git mainline, where bleeding-edge
 development takes place.  These "Packagers" produce binary releases of
-OpenOCD after the developers produces new "stable" versions of the
-source code.  Previous versions of OpenOCD cannot be used to diagnosed
+OpenOCD after the developers produces new "release" versions of the
+source code.  Previous versions of OpenOCD cannot be used to diagnose
 problems with the current release, so users are encouraged to keep in
 contact with their distribution package maintainers or interface vendors
 to ensure suitable upgrades appear regularly.
@@ -119,7 +125,7 @@ Building OpenOCD
 The INSTALL file contains generic instructions for running 'configure'
 and compiling the OpenOCD source code.  That file is provided by default
 for all GNU automake packages.  If you are not familiar with the GNU
-autotools, then you should read those instructions first.  
+autotools, then you should read those instructions first.
 
 The remainder of this document tries to provide some instructions for
 those looking for a quick-install.
@@ -157,7 +163,7 @@ To build OpenOCD (on both Linux and Cygwin), use the following sequence
 of commands:
 
    ./configure [with some options listed in the next section]
-   make 
+   make
    make install
 
 The 'configure' step generates the Makefiles required to build OpenOCD,
@@ -166,6 +172,29 @@ will build OpenOCD and place the final executable in ./src/.  The
 final (optional) step, ``make install'', places all of the files in the
 required location.
 
+Cross-Compiling Options
+-----------------------
+
+To cross-compile, you must specify both --build and --host options to
+the 'configure' script.  For example, you can configure OpenOCD to
+cross-compile on a x86 Linux host to run on Windows (MinGW32), you could
+use the following configuration options:
+
+  ./configure --build=i686-pc-linux-gnu --host=i586-mingw32msvc ...
+
+Likewise, the following options allow OpenOCD to be cross-compiled for
+an ARM target on the same x86 host:
+
+  ./configure --build=i686-pc-linux-gnu --host=arm-elf ...
+
+Both must be specified to work around bugs in autoconf.
+
+Scripts for producing ARM cross-compilers can be found on the web with a
+little searching.  A script to produce an x86 Linux-hosted MinGW32
+cross-compiler can be downloaded from the following URL:
+
+  http://www.mingw.org/wiki/LinuxCrossMinGW
+
 Configuration Options
 ---------------------
 
@@ -176,7 +205,7 @@ options may be available there:
 
   --enable-maintainer-mode  enable make rules and dependencies not useful
                           (and sometimes confusing) to the casual installer
-                         NOTE: This option is *required* for SVN builds!
+                         NOTE: This option is *required* for GIT builds!
                          It should *not* be used to build a release.
 
   --enable-dummy          Enable building the dummy JTAG port driver
@@ -186,9 +215,6 @@ options may be available there:
                           FTD2XX
   --enable-ft2232_ftd2xx  Enable building support for FT2232 based devices
                           using the FTD2XX driver from ftdichip.com
-  --enable-ftd2xx-highspeed
-                          Enable building support for FT2232H and
-                          FT4232H-based devices (requires >=libftd2xx-0.4.16)
 
   --enable-gw16012        Enable building support for the Gateworks GW16012
                           JTAG Programmer
@@ -210,6 +236,8 @@ options may be available there:
                           Programmer
   --enable-rlink          Enable building support for the Raisonance RLink
                           JTAG Programmer
+  --enable-ulink          Enable building support for the Keil ULINK JTAG
+                          Programmer
   --enable-usbprog        Enable building support for the usbprog JTAG
                           Programmer
   --enable-vsllink        Enable building support for the Versaloon-Link JTAG
@@ -229,8 +257,9 @@ options may be available there:
 
   --enable-ioutil         Enable ioutil functions - useful for standalone
                           OpenOCD implementations
-  --enable-httpd          Enable builtin httpd server - useful for standalone
-                          OpenOCD implementations
+
+  --disable-doxygen-html Disable building Doxygen manual as HTML.
+  --enable-doxygen-pdf   Enable building Doxygen manual as PDF.
 
 Miscellaneous Configure Options
 -------------------------------
@@ -272,22 +301,26 @@ have to use both the --enable-parport AND the --enable-parport-giveio
 option if you want to use giveio instead of ioperm parallel port access
 method.
 
-FT2232C Based USB Dongles 
+FT2232C Based USB Dongles
 -------------------------
 
 There are 2 methods of using the FTD2232, either (1) using the
 FTDICHIP.COM closed source driver, or (2) the open (and free) driver
-libftdi. 
+libftdi.
 
 Using LIBFTDI
 -------------
 
+The libftdi source code can be download from the following website:
+
+  http://www.intra2net.com/en/developer/libftdi/download.php
+
 For both Linux and Windows, both libusb and libftdi must be built and
 installed.  To use the newer FT2232H chips, supporting RTCK and USB high
-speed (480 Mbps), you need libftdi version 0.16 or newer.  Many Linux
+speed (480 Mbps), use libftdi version 0.17 or newer.  Many Linux
 distributions provide suitable packages for these libraries.
 
-For Windows, libftdi is supported with versions 0.14 and later.  
+For Windows, libftdi is supported with versions 0.14 and later.
 
 With these prerequisites met, configure the libftdi solution like this:
 
@@ -298,16 +331,16 @@ Then type ``make'', and perhaps ``make install''.
 Using FTDI's FTD2XX
 -------------------
 
-Some claim the (closed) FTDICHIP.COM solution is faster, which
+The (closed source) FTDICHIP.COM solution is faster on MS-Windows.  That
 is the motivation for supporting it even though its licensing restricts
 it to non-redistributable OpenOCD binaries, and it is not available for
 all operating systems used with OpenOCD.  You may, however, build such
 copies for personal use.
 
 The FTDICHIP drivers come as either a (win32) ZIP file, or a (Linux)
-TAR.GZ file. You must unpack them ``some where'' convient. As of this
+TAR.GZ file. You must unpack them ``some where'' convenient. As of this
 writing FTDICHIP does not supply means to install these files "in an
-appropriate place."  
+appropriate place."
 
 If your distribution does not package these, there are several
 './configure' options to solve this problem:
@@ -328,20 +361,7 @@ Windows or Linux FTD2xx drivers from the following location:
 Remember, this library is binary-only, while OpenOCD is licenced
 according to GNU GPLv2 without any exceptions.  That means that
 _distributing_ copies of OpenOCD built with the FTDI code would violate
-the OpenOCD licensing terms.  
-
-
-Cygwin/Win32 Notes
-******************
-
-The Cygwin/Win32 ZIP file contains a directory named ftd2xx.win32.
-Assuming that you have extracted this archive in the same directory as
-the OpenOCD package, you could configure with options like the following:
-
-   ./configure \
-       --enable-ft2232_ftd2xx \
-       --with-ftd2xx-win32-zipdir=../ftd2xx.win32 \
-       ... other options ...
+the OpenOCD licensing terms.
 
 Linux Notes
 ***********
@@ -356,41 +376,50 @@ the following:
         --with-ft2xx-linux-tardir=../libftd2xx0.4.16 \
        ... other options ...
 
-=================================
-Obtaining OpenOCD From Subversion
----------------------------------
+Note that on Linux there is no good reason to use these FTDI binaries;
+they are no faster (on Linux) than libftdi, and cause licensing issues.
+
+==========================
+Obtaining OpenOCD From GIT
+==========================
+
+You can download the current GIT version with a GIT client of your
+choice from the main repository:
 
-You can download the current SVN version with an SVN client of your
-choice from the following repositories:
+   git://openocd.git.sourceforge.net/gitroot/openocd/openocd
 
-   svn://svn.berlios.de/openocd/trunk
-or
-   http://svn.berlios.de/svnroot/repos/openocd/trunk
+You may prefer to use a mirror:
 
-Using the SVN command line client, you can use the following command to
-fetch the latest version (make sure there is no (non-svn) directory
-called "openocd" in the current directory):
+   http://repo.or.cz/r/openocd.git
+   git://repo.or.cz/openocd.git
 
-   svn checkout svn://svn.berlios.de/openocd/trunk openocd
+Using the GIT command line client, you might use the following command
+to set up a local copy of the current repository (make sure there is no
+directory called "openocd" in the current directory):
 
-If you prefer GIT based tools, the git-svn package works too:
+   git clone git://openocd.git.sourceforge.net/gitroot/openocd/openocd
 
-   git svn clone -s svn://svn.berlios.de/openocd
+Then you can update that at your convenience using
 
-Tips For Building From The Subversion Repository
-************************************************
+   git pull
+
+There is also a gitweb interface, which you can use either to browse
+the repository or to download arbitrary snapshots using HTTP:
+
+   http://openocd.git.sourceforge.net/git/gitweb.cgi?p=openocd/openocd
+   http://repo.or.cz/w/openocd.git
+
+Snapshots are compressed tarballs of the source tree, about 1.3 MBytes
+each at this writing.
+
+
+Tips For Building From a GIT Repository
+---------------------------------------
 
 Building OpenOCD from a repository requires a recent version of the GNU
-autotools (autoconf >= 2.59 and automake >= 1.9).  For building on
-Windows, you have to use Cygwin. Make sure that your PATH
-environment variable contains no other locations with Unix utils (like
-UnxUtils) - these can't handle the Cygwin paths, resulting in obscure
-dependency errors.  This was an observation gathered from the logs of
-one user; please correct us if this is wrong.
+autotools (autoconf >= 2.59 and automake >= 1.9).
 
 1) Run './bootstrap' to create the 'configure' script and prepare
    the build process for your host system.
 
 2) Run './configure --enable-maintainer-mode' with other options.
-
-