Add 'docs' and 'doxygen' targets to top-level Makefile.
[openocd.git] / bootstrap
1 #!/bin/sh -e
2
3 if libtoolize --version >/dev/null 2>&1; then
4         libtoolize="libtoolize"
5 elif glibtoolize --version >/dev/null 2>&1; then
6         libtoolize="glibtoolize"
7 else
8         echo "libtool is required" >&2
9         exit 1
10 fi
11
12 # bootstrap the autotools
13 (
14 set -x
15 aclocal
16 autoheader
17 ${libtoolize} --automake --copy
18 autoconf
19 autoheader
20 automake --foreign --add-missing --copy
21 )
22
23 # AM_MAINTAINER_MODE requires SVN users provide --enable-maintainer-mode
24 # otherwise the documentation will fail to build due to missing version.texi
25 echo "Bootstrap complete; you can './configure --enable-maintainer-mode ....'"