268d07c16fc9536df4bc817ab7f2d99f8dbeec99
[openocd.git] / bootstrap
1 #!/bin/sh -e
2 # Run the autotools bootstrap sequence to create the configure script
3
4 # Stop execution as soon as we have an unknown command 
5 set -e
6
7 if libtoolize --version >/dev/null 2>&1; then
8         libtoolize="libtoolize"
9 elif glibtoolize --version >/dev/null 2>&1; then
10         libtoolize="glibtoolize"
11 else
12         echo "libtool is required" >&2
13         exit 1
14 fi
15
16 # bootstrap the autotools
17 (
18 set -x
19 aclocal
20 ${libtoolize} --automake --copy
21 autoconf
22 autoheader
23 automake --gnu --add-missing --copy
24 )
25
26 # AM_MAINTAINER_MODE requires --enable-maintainer-mode from everyone using
27 # current source snapshots (working from GIT, or some source snapshot, etc)
28 # otherwise the documentation will fail to build due to missing version.texi
29 echo "Bootstrap complete; you can './configure --enable-maintainer-mode ....'"